Bu hata için çok uğraştım ve daha ilginci internette doyurucu bilgi bulamadım. Düşündüm taşındım çok komik ve basit bir sebeptenmiş. Ben php 5.2.x kullanıyorum ama çağırdığım dosya  ioncube_loader_lin_5.1.so  yani php 5.1.x kullananlar için.

Yapılacak işlem çok basit. ioncube-loader.ini dosyasını açıyoruz ve ioncube-loader versiyonunu php versiyonumuzla aynı yapıyoruz. Yani  benim gibi php 5.2.x e geçmiş iseniz :

php_ioncube_loader_lin_5.1.so

Dosya adını ;

php_ioncube_loader_lin_5.2.so

Olarak değiştiriyoruz, bu kadar basit. ioncube-loader.ini dosyası bende  /etc/php.d/ kalsöründe değişik Linux versiyonlarına göre değişik yerlerde olabilir.